Delayed monitor notifications

Incident Report for Datadog Govcloud

Resolved

We have confirmed recovery of delays in Monitors Notifications involving monitors which rely on distribution metrics as of 17:49 UTC
Posted May 27, 2025 - 14:10 EDT

Monitoring

We have deployed a fix for delays in Monitors Notifications involving monitors which rely on distribution metrics, which began at 15:20 UTC and are monitoring the fix.
Posted May 27, 2025 - 13:24 EDT

Investigating

We are still investigating for delays in Monitors Notifications involving monitors which rely on distribution metrics, which began at 15:20 UTC.
Posted May 27, 2025 - 12:01 EDT
This incident affected: Monitors.