Delayed Monitors Notifications

Incident Report for Datadog Govcloud

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 12:59 EST

Investigating

We are investigating delays in Monitors Notifications, which began at 16:20 UTC.
Posted Jan 14, 2026 - 12:42 EST
This incident affected: Monitors.