Delayed [CLOUD PROVIDER: AWS/GCP/...] Events

Incident Report for Datadog Govcloud

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 10:34 EDT

Investigating

We are recovering from increased latency processing monitors from cloud providers. Some users may receive delayed alerts from cloud integrations monitors that activated after 13:45 UTC
Posted Apr 22, 2025 - 10:11 EDT
This incident affected: Cloud Integrations.