Delayed Monitors Notifications

Incident Report for Datadog Govcloud

Resolved

This incident has been resolved.
Posted Sep 21, 2024 - 06:49 EDT

Update

The issue causing delays in Monitor Notifications for monitors with metric queries over time windows longer than one hour has been largely resolved. The impact is now limited to a small percentage of monitors affecting a subset of customers. We are closely monitoring the situation and will provide a final update once the issue is fully resolved.
Posted Sep 20, 2024 - 19:57 EDT

Monitoring

We have deployed a fix and are currently monitoring the results. Further updates will be provided as we continue to make progress toward full recovery.
Posted Sep 20, 2024 - 18:21 EDT

Investigating

We are investigating delays in Monitors Notifications for metric queries with time windows longer than 1 hour, which began at 7:35 PM UTC.
Posted Sep 20, 2024 - 16:58 EDT
This incident affected: Monitors.