Delayed Metrics

Incident Report for Datadog Govcloud

Resolved

This incident has been resolved.
Posted Apr 04, 2026 - 03:41 EDT

Monitoring

A fix has been implemented and we are waiting for data to backfill.
Posted Apr 04, 2026 - 03:14 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 04, 2026 - 03:12 EDT

Investigating

We are investigating increased latency processing Metrics.
As a result of this issue, some users may see delays or gaps for metrics on graphs.

To prevent false monitor alerts due to delayed data, monitors affected by the delay will not notify and will automatically resume once current data is available. All other monitors will operate normally.
Posted Apr 04, 2026 - 02:50 EDT
This incident affected: Metrics and Infra Monitoring.